Hidden Observers stream

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted May 04, 2026 - 13:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 13:22 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2026 - 12:20 PDT

Investigating

We are currently investigating an issue where the stream for hidden observers is not available during Live Conversations.

As a temporary workaround, users can join the session as co-moderators to access the stream.

We will provide further updates as soon as more information becomes available.
Posted May 04, 2026 - 11:45 PDT
This incident affected: Recording Services (Live Conversations).