Reports of some users not being able to sign into their Accounts

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted May 01, 2026 - 12:36 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 10:40 PDT

Investigating

We have received reports from multiple users not being able to sign into their accounts. We are investigating. Thank you so much for your patience. We will provide an update when we know more. We apologize for the inconvenience.
Posted May 01, 2026 - 10:16 PDT
This incident affected: Customer Dashboard (Dashboard).