Issues adding an audience to a test

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 06:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 06:01 PDT

Identified

We have identified an issue affecting the ability to add an audience to a test and are implementing a fix. We apologize for the inconvenience.
Posted Apr 30, 2026 - 04:44 PDT
This incident affected: Ordering (Test Launch Flow).