Investigating reports of website slowness
Incident Report for UserTesting
Resolved
The issue has been resolved.
Posted May 04, 2023 - 16:20 PDT
Monitoring
We are monitoring the issue with our application being slow.
Posted May 04, 2023 - 12:35 PDT
Investigating
We’re investigating an issue with our application being slow. We will update this page as we have more information.
Posted May 04, 2023 - 11:37 PDT
This incident affected: Ordering (Test Launch Flow) and Customer Dashboard (Dashboard, Study Results, Insights Summary).