Intermittent issues when loading the platform
Incident Report for UserTesting
Resolved
We are no longer seeing any issues and the platform is working as expected. Thanks for your patience.
Posted Feb 22, 2024 - 09:39 PST
Monitoring
We are seeing some reports of degraded performance loading the platform. Our engineering team is actively investigating and monitoring. Apologies for the inconvenience.
Posted Feb 22, 2024 - 08:37 PST
This incident affected: Customer Dashboard (Dashboard).