Degraded Performance
Incident Report for UserTesting
Resolved
This incident has been resolved.
Posted May 19, 2023 - 10:56 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2023 - 10:14 PDT
Identified
We’ve received reports that "Add Contributors" feature is not functioning for launched studies. Our engineering team is actively investigating. The root cause has been identified already.
Posted May 19, 2023 - 09:57 PDT
This incident affected: Ordering (Test Launch Flow).