Results page loading slowly for some Surveys or Interaction tests

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 03:35 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2025 - 00:14 PDT

Identified

We're investigating an issue which might cause the Results page to load slowly for some Surveys or Interaction tests.
Posted Jun 03, 2025 - 15:11 PDT
This incident affected: Customer Dashboard (Study Results).