Slow loading in Surveys and Interaction Tests results

Incident Report for UserTesting

Resolved

The incident has been resolved and results are loading at normal speed in all studies. Thank you for your patience.
Posted May 16, 2025 - 10:21 PDT

Monitoring

A fix has been added to restore the loading time in Surveys and Interaction Tests. We are still monitoring but the studies should load correctly now.
Posted May 16, 2025 - 09:14 PDT

Investigating

We are currently investigating slow loading for the results page on both Surveys and Interaction Tests studies. We will keep updating once we identify what the issue is. Apologies for the inconvenience.
Posted May 16, 2025 - 07:10 PDT
This incident affected: Customer Dashboard (Study Results).