Usertesting platform down.

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 12:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 11:52 PDT

Investigating

We are currently experiencing an issue affecting access to the UserTesting platform. Our team is actively investigating, and we will provide updates as soon as more information becomes available.
Posted Mar 10, 2026 - 11:28 PDT
This incident affected: Customer Dashboard (Dashboard, Study Results, Insights Summary) and Ordering (Login Portal).