We're investigating reports that the dashboard is extremely slow or not loading for some users

Incident Report for UserTesting

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 08:22 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 07:45 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 06, 2025 - 07:26 PST

Update

We are continuing to investigate this issue.
Posted Nov 06, 2025 - 06:57 PST

Investigating

We are currently investigating this issue.
Posted Nov 06, 2025 - 06:53 PST
This incident affected: Video Management (Video Playback, Highlight Reel Editor), Ordering (Test Launch Flow, Login Portal), Customer Dashboard (Dashboard, Study Results, Insights Summary), and Fulfillment Services (Tester Dashboard).