Some pages under www.usertesting.com are not loading.

Incident Report for UserTesting

Resolved

The incident is resolved and all pages in our Marketing website www.usertesting.com should be loading as expected. Apologies for the inconvenience and thank you for your patience.
Posted Nov 28, 2025 - 09:36 PST

Update

We are aware of issues loading the www.usertesting.com page intermittently. Our team is working on it and will provide updates as it's resolved. This issue is not impacting our UserTesting Platform for either customers or contributors. Thank you for your patience.
Posted Nov 28, 2025 - 04:40 PST

Investigating

We are currently investigating this issue.
Posted Nov 28, 2025 - 01:49 PST
This incident affected: Logged Out Application (Marketing Site).