Issues accessing the Tester Dashboard
Incident Report for UserTesting
Resolved
This issue is now fully resolved - thank you for your patience.
Posted May 02, 2024 - 12:33 PDT
Identified
We are receiving reports of some of our contributors having issues accessing the available studies dashboard. We have identified the root cause and are working to restore the access as soon as possible. Apologies for the inconvenience.
Posted May 02, 2024 - 11:09 PDT
This incident affected: Fulfillment Services (Tester Dashboard).