Issues trying to load the dashboard when logging into the platform

Incident Report for UserTesting

Resolved

This incident is resolved now. The dashboard should be loading correctly for all users. Apologies for the inconvenience and thank you for your patience.
Posted Nov 19, 2025 - 03:53 PST

Investigating

We are getting some reports of issues loading the Studies dashboard when logging in. We are investigating and will update with more information as soon as we have it. Thank you for your patience.
Posted Nov 19, 2025 - 03:26 PST
This incident affected: Customer Dashboard (Dashboard).